using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((<)(\/|)(?!a|h1)([a-zA-Z0-9]+))";
string substitution = @"\n\1";
string input = @"<!-- Comments Testing -->
<div id=""page""><div id=""header""><h1><a href=""#"">Burger Pointer</a></h1><ul class=""left""><li><a href=""#"">Menu</a></li><li><a href=""#"">Location</a></li><li><a href=""#"">About Us</a></li><li><a href=""#"">BP Gear</a></li></ul></div></div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}