re = /((<)(\/|)(?!a|h1)([a-zA-Z0-9]+))/
str = '<!-- Comments Testing -->
<div id="page"><div id="header"><h1><a href="#">Burger Pointer</a></h1><ul class="left"><li><a href="#">Menu</a></li><li><a href="#">Location</a></li><li><a href="#">About Us</a></li><li><a href="#">BP Gear</a></li></ul></div></div>'
subst = '\\n\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result