const regex = /.*martian.*source.*\n.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*martian.*source.*\\n.*', 'gm')
const str = `Jan 10 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0
Jan 11 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5
Jan 12 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 13 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 14 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 15 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 16 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 17 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 18 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 19 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 20 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 21 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 22 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 23 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 23 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 24 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 25 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0
Jan 25 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5
Jan 26 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0
Jan 26 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5
Jan 27 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 28 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0
Jan 28 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}