$re = '/(?<=^Welcome Back)\s*([\w\s]*)(?=\.)/';
$str = 'Welcome Back Kumar Singh. ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);