use strict;
my $str = '
CALNET à l\'équipe COFELY RAA
Vous venez de signaler la réalisation de la visite de maintenance pour la visite n° MAINT0218037 faite le 21/05/2019 14:22:30 sur le site RRAA BRIOUDE (00223200). Il vous reste maintenant à publier le rapport de maintenance dans CALNET.
Pour ce faire, vous pouvez accéder au dossier en cliquant sur ce lien : ici .
Cordialement
';
my $regex = qr/(?:dossier|facture|visite)\s*n\xB0\s*(?:INC|MAINT)[0-9]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}