import Foundation
let pattern = #"(?:dossier|facture|visite)\s*n\xB0\s*(?:INC|MAINT)[0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CALNET à l'équipe COFELY RAA
Vous venez de signaler la réalisation de la visite de maintenance pour la visite n° MAINT0218037 faite le 21/05/2019 14:22:30 sur le site RRAA BRIOUDE (00223200). Il vous reste maintenant à publier le rapport de maintenance dans CALNET.
Pour ce faire, vous pouvez accéder au dossier en cliquant sur ce lien : ici .
Cordialement
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)