#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(\()|({)|\[)(?(1)[^)\d]*\)|(?(2)[^}\d]*}|[^]\d]*]))\s*"
Local $sString = "# (1437)" & @CRLF & _
"# {19} (917) (1437)" & @CRLF & _
"# {19} (1437) [1449] [2474] [2098] [1351] [508] [969]( MONDAY) [sunday]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)