#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9_-]+$"
Local $sString = "gamertag" & @CRLF & _
"GamerTag" & @CRLF & _
"Gamer_Tag" & @CRLF & _
"_GamerTag" & @CRLF & _
"GamerTag_-" & @CRLF & _
"GamerTag" & @CRLF & _
"Gamer-Tag" & @CRLF & _
"GamerTag-" & @CRLF & _
"" & @CRLF & _
"!GamerTag" & @CRLF & _
"Gamer%Tag" & @CRLF & _
"Gamer Tag"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")