using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9_-]+$";
string input = @"gamertag
GamerTag
Gamer_Tag
_GamerTag
GamerTag_-
GamerTag
Gamer-Tag
GamerTag-
!GamerTag
Gamer%Tag
Gamer Tag";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}