#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.com$)"
Local $sString = "abc" & @CRLF & _
"abs@gmail.com sss" & @CRLF & _
"abs@gmail.comsss" & @CRLF & _
"aaaabs@gmail.com" & @CRLF & _
"aaa abs@gmail.com" & @CRLF & _
"abc@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")