$re = '/^(?![a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.com$)/m';
$str = 'abc
abs@gmail.com sss
abs@gmail.comsss
aaaabs@gmail.com
aaa abs@gmail.com
abc@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);