$re = '/\W*\b[A-Z]+\b(?!\'\b)\.?/m';
$str = 'John O\'Connele MCA,MD.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;