Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(-?\d*(?:\.?\d*)?(?:e[-+]?\d*)?)
/
gm
Input 1
1
New
0.9 -.4 -0.5 9 -6 -1.0e-1 -10.56e-1 2.93847293841270e+16 -4.65981524854648e+16