$re = '/^(?!.*\b(?:update|delete)user\b).+$/m';
$str = 'updateuser
deleteuser
the rest';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);