import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_[\\]]+)\\s?((=|<|>|<=|>=)=?)\\s?([-+]?([0-9]*\\.[0-9]+|[0-9]+))\\s?\\(?(\\w*)\\)?(?:\\sfor|\\sin)?\\s?([0-9]*\\.[0-9]+|[0-9]+)?(s|ms|min|us)?(?:\\sfor)?\\s?([0-9]*\\.[0-9]+|[0-9]+)?(s|ms|min|us)?";
final String string = "Em01_Trq = 500 rpm\n"
+ "Em01_Trq=-500rpm\n"
+ "Em01_Trq<+500rpm in 100ms for 10s\n"
+ "Em01_Trq<=-500rpm for 10s\n"
+ "Em01_Trq>=-500rpm in 10.5s\n"
+ "Em01_Trq>-500.505rpm\n"
+ "Em_md = 1(Torque)\n"
+ "Em_md = 1(Torque) in 50ms\n"
+ "Em_md = 1(Torque) \n"
+ "[Em_md] = 1(Torque) for 50.1min\n"
+ "Em01_Trq = 500 rpm";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}