import re
regex = re.compile(r"([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?(?:\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(?:\sfor)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?")
test_str = ("Em01_Trq = 500 rpm\n"
"Em01_Trq=-500rpm\n"
"Em01_Trq<+500rpm in 100ms for 10s\n"
"Em01_Trq<=-500rpm for 10s\n"
"Em01_Trq>=-500rpm in 10.5s\n"
"Em01_Trq>-500.505rpm\n"
"Em_md = 1(Torque)\n"
"Em_md = 1(Torque) in 50ms\n"
"Em_md = 1(Torque) \n"
"[Em_md] = 1(Torque) for 50.1min\n"
"Em01_Trq = 500 rpm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")