$re = '/[A-Za-z]+ +[1-2]?[0-9]\b/';
$str = 'Sam
Tom 29';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);