$re = '/[A-Z].*?[\.!?]/m';
$str = 'My name is UKKO. Nice to meet you. Have a Nice day!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);