using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*/(abc\d{2})(?:/.*)?$";
string substitution = @"\1";
string input = @"/path/path/path/abc22/path/path
/apath/apath/paath/abc11/something/path";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}