$re = '/^(?=.*(\w).\1)(?=.*(\w\w).+\2).*/m';
$str = 'qjhvhtzxzqqjkmpb
xxyxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);