#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\d)(?:\d*\.)?\d+"
Local $sString = ".1875 X 7.00 X 8.800 " & @CRLF & _
"7.00 X .1875 X 8.800 " & @CRLF & _
".50" x 1.25" x 7.125" will make one part" & @CRLF & _
"" & @CRLF & _
".1875 X 7.00 X 8.800 X 456 X 13.45.56.343.343." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")