using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(?:\d*\.)?\d+";
string input = @".1875 X 7.00 X 8.800
7.00 X .1875 X 8.800
.50"" x 1.25"" x 7.125"" will make one part
.1875 X 7.00 X 8.800 X 456 X 13.45.56.343.343.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}