package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:,\d+)*$`)
var str = `9
9,65
1,2,4,55,4
,545
76657,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}