# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+).*?(,(?=.*\d))|\D/$1$2/gm;t' <<< ",,,,1,,2dgd,d,"