using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:
(https?) :/{2}
)?
(
\w+
(?:\.\w+)+
)";
string input = @"example.com
www.example.com
http://example.com
https://example.com
http://www.one.two.three.example.com
example.com/stuff
example.com/?key1=value1
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}