using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^:;\n]*)(:\d+)?;([^;\n]*)(;.*\b\3\b=|;.*;|;)(\d+)(,.*|;)?$";
string input = @"# with k/v pairs declared
app.default.svc.local;http-metrics;http-metrics=9090;
app.default.svc.local;http-metrics;;http-metrics=9090
app.default.svc.local;http-metrics;http-server=9090;
app.default.svc.local:8000;http-metrics;http-metrics=9090;
app.default.svc.local:8000;http-metrics;;http-metrics=9090
app.default.svc.local:8000;http-metrics;http-server=9090;
app.default.svc.local;http-metrics;http-metrics=9090,http-server=8000;
app.default.svc.local;http-metrics;;http-metrics=9090,http-server=8000
app.default.svc.local;http-metrics;http-server=9090,http-server=8000;
app.default.svc.local:8000;http-metrics;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-metrics;;http-metrics=9090,http-server=8000
app.default.svc.local:8000;http-metrics;http-server=9090;
app.default.svc.local;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local;http-server;;http-metrics=9090,http-server=8000
app.default.svc.local;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-server;;http-metrics=9090,http-server=8000
app.default.svc.local:8000;http-server;http-metrics=9090;
# without k/v pairs
app.default.svc.local;http-metrics;9090;
app.default.svc.local;http-metrics;;9090
app.default.svc.local;http-metrics;http-server=9090;
app.default.svc.local:8000;http-metrics;9090;
app.default.svc.local:8000;http-metrics;;9090
app.default.svc.local:8000;http-metrics;http-server=9090;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}