const regex = /Server Version: \K\d+(?:\.\d+)+(?= Kubernetes)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Server Version: \\K\\d+(?:\\.\\d+)+(?= Kubernetes)', 'gm')
const str = `Client Version: openshift-clients-4.3.0-201910250623-88-g6a937dfe Server Version: 4.3.0 Kubernetes Version: v1.16.2:q`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}