re = /Server Version: \K\d+(?:\.\d+)+(?= Kubernetes)/m
str = 'Client Version: openshift-clients-4.3.0-201910250623-88-g6a937dfe Server Version: 4.3.0 Kubernetes Version: v1.16.2:q'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end