$re = '/((^|;)Password=)(.*?)(;|$)/im';
$str = 'Host=SERVERNAME;Port=####;Database=DBNAME;Username=USERID;Password=MyPa$$Word;Integrated Security=False
Host=SERVERNAME;Port=9999;Password=MyPa$$Word;Database=DBNAME;Username=USERID;Integrated Security=False
Host=SERVERNAME;Port=9999;Database=DBNAME;Username=USERID;Integrated Security=False;Password=MyPa$$Word
Host=SERVERNAME;Port=9999;Database=DBNAME;Username=USERID;Integrated Security=False;Password=Password';
$subst = "$1PASSWORD_REMOVED$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;