import re
regex = re.compile(r"((^|;)Password=)(.*?)(;|$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Host=SERVERNAME;Port=####;Database=DBNAME;Username=USERID;Password=MyPa$$Word;Integrated Security=False\n"
"Host=SERVERNAME;Port=9999;Password=MyPa$$Word;Database=DBNAME;Username=USERID;Integrated Security=False\n"
"Host=SERVERNAME;Port=9999;Database=DBNAME;Username=USERID;Integrated Security=False;Password=MyPa$$Word\n"
"Host=SERVERNAME;Port=9999;Database=DBNAME;Username=USERID;Integrated Security=False;Password=Password")
subst = "$1PASSWORD_REMOVED$4"
result = regex.sub(subst, test_str)
if result:
print(result)