$re = '/^([0-1]?[0-9]|2[0-4]):([0-5][0-9])(:[0-5][0-9])?$/m';
$str = '02:05
23:50
14:28
25:00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);