use strict;
my $str = ' options: [{
value: "120",
id: "40",
title: "1400g",
name: "Tamanho: 123"
},
{
value: "336",
id: "60",
title: "Chocolate",
name: "Sabor"
}
]';
my $regex = qr/(\w+)(\:)/mp;
my $subst = '\\"$1\\"$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";