#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9a-fA-F]{1,2}$|^[0-9a-fA-F]{1,2}\s+([0-9a-fA-F]{1,2}\s)*[0-9a-fA-F]{1,2}$"
Local $sString = "0" & @CRLF & _
"00" & @CRLF & _
"000" & @CRLF & _
"0000" & @CRLF & _
"00000" & @CRLF & _
"000000" & @CRLF & _
"aa bb cc dd ee ff 00" & @CRLF & _
"AA BB CC DD EE FF" & @CRLF & _
"00" & @CRLF & _
"00 " & @CRLF & _
"00 0" & @CRLF & _
"00 00" & @CRLF & _
"00 00" & @CRLF & _
"00 00 0" & @CRLF & _
"00 00 00 00" & @CRLF & _
"00 00 00" & @CRLF & _
"00 00 00 00 00 00 00 00 00" & @CRLF & _
"aa bb cd ef 11 dd" & @CRLF & _
"a bf 11 cd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")