re = /^[0-9a-fA-F]{1,2}$|^[0-9a-fA-F]{1,2}\s+([0-9a-fA-F]{1,2}\s)*[0-9a-fA-F]{1,2}$/m
str = '0
00
000
0000
00000
000000
aa bb cc dd ee ff 00
AA BB CC DD EE FF
00
00
00 0
00 00
00 00
00 00 0
00 00 00 00
00 00 00
00 00 00 00 00 00 00 00 00
aa bb cd ef 11 dd
a bf 11 cd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end