package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<p.+id="sinopse2"[^>*]*>(.*)<\/p>`)
var str = `<p id="sinopse2" style="display:block !important;">VALOOR</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}