$re = '/<p.+id="sinopse2"[^>*]*>(.*)<\/p>/m';
$str = '<p id="sinopse2" style="display:block !important;">VALOOR</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);