re = /<p.+id="sinopse2"[^>*]*>(.*)<\/p>/m
str = '<p id="sinopse2" style="display:block !important;">VALOOR</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end