using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(\s*,\s*(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}))*";
string substitution = @"";
string input = @"10.1.1.1,123.123.123.123,192.192.192.192";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}