using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=_).+";
string substitution = @"";
string input = @"John Smith_12345678_
Mary Scott_87945687_
William Tell_9875348_
Jane Doe_57982388_";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}