use strict;
my $str = 'FOR INHALATION AND ORAL ROUTES : NSRL - Oral: 6.4 µg/day and MADL - Oral : 24 µg/day NSRL - Inhalation: 13 µg/day and MADL - Inhalation: 49 µg/day Only if concentration of this substance is higher than the safe harbor level (ingredient or impurity) : This product can expose you to chemicals including [name of one or more chemicals], which is [are] known to the State of California to cause [cancer] and [birth defects or other reproductive harm]';
my $regex = qr/(.*NSRL(.*:.\D*\d*).*µg\/day)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}