// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*NSRL(.*:.\D*\d*).*µg\/day)").unwrap();
let string = "FOR INHALATION AND ORAL ROUTES : NSRL - Oral: 6.4 µg/day and MADL - Oral : 24 µg/day NSRL - Inhalation: 13 µg/day and MADL - Inhalation: 49 µg/day Only if concentration of this substance is higher than the safe harbor level (ingredient or impurity) : This product can expose you to chemicals including [name of one or more chemicals], which is [are] known to the State of California to cause [cancer] and [birth defects or other reproductive harm]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}