$re = '/\d+\.\d+\.\d+\.\d+(\/.\d+|)/m';
$str = '1.1.1.1
133.144.155.166/24
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);