#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^0+(\d)|(\d)0+$"
Local $sString = "00001011100000" & @CRLF & _
"000" & @CRLF & _
"000000123" & @CRLF & _
"000000456000000000000" & @CRLF & _
"789000"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)