using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0+(\d)|(\d)0+$";
string substitution = @"$1$2";
string input = @"00001011100000
000
000000123
000000456000000000000
789000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}