re = /^0+(\d)|(\d)0+$/m
str = '00001011100000
000
000000123
000000456000000000000
789000'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result