use strict;
my $str = '<p>Bene eros jus neo olim pecus suscipit. </p>
[collapse in]
<h2>titel</h2>
<p>Illum iriure neo populus refoveo.</p>
<h3>titel</h3>
<p>Illum iriure neo populus refoveo.</p>
<h2>titel</h>
<p>Illum iriure neo populus refoveo.</p>
[/collapse]
[collapse]
<h3>titel2</h3>
<p>Illum iriure neo populus refoveo.</p> [/collapse]';
my $regex = qr/\[(collapse|collapse in)\]\s*<(h[2-4])>(.*)<\/\2>(.*)\s*\[\/collapse\]/sp;
my $subst = '<\\2 data-target="#\\3" data-toggle="\\1">\\3</\\2>\\n<div id="\\3" class="collapse">\\4</div>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";