# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<host>[\w\-]+)(?=\.fully\.qualified\.domain\.name\.com).*?\b(?<ip>(?:(?:2(?:[0-4][0-9]|5[0-5])|[0-1]?[0-9]?[0-9])\.){3}(?:(?:2([0-4][0-9]|5[0-5])|[0-1]?[0-9]?[0-9])))\b.*?(?<filename>[a-zA-Z]:\\(?:[^\\\/:*?\"<>|\r\n]+\\)*[^\\\/:*?\"<>|\r\n]*)(?=<br\s*\/?>)"
test_str = ("<td class=\"#ffffff\" style=\" \" colspan=\"1\">DNS Name:</td> <td class=\"#ffffff\" style=\" \" colspan=\"1\">comp-uter-123.fully.qualified.domain.name.com</td>\n\n"
"<snip few lines of crap>\n\n"
"<td class=\"#ffffff\" style=\" \" colspan=\"1\">IP:</td> <td class=\"#ffffff\" style=\" \" colspan=\"1\">10.0.0.10</td>\n\n"
"<snip like 150 lines of BS>\n\n"
"And then there's between 1 and maybe 50 of the below.\n\n"
"<h2>tcp/445/cifs</h2> <div class=\"clear\"></div> <div style=\"box-sizing: border-box; width: 100%; background: #eee; font-family: monospace; padding: 20px; margin: 5px 0 20px 0;\"> <br> Path : C:\\Users\\username\\dir1\\dir2\\dir3\\dir4\\filename.exe<br> Installed version : 1.2.12<div class=\"clear\"></div>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.