import re
regex = re.compile(r"(?:vnc|s3|ssh|scp|sftp|ftp|http|https)\:\/\/[\w\.]+(?:\:?\d{0,5})|(?:mailto|)\:[\w\.]+\@[\w\.]+")
test_str = ("http://www.site1.com/perma/doom-rock.htm\n"
"http://www.site2.net/mod/doom.html\n"
"https://www.site3.com/m/doom-rock\n"
"http://site4.com/doom\n"
"https://site5.com/doom")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")