using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z a-z 0-9 * - + = _ . # ~ ! ]{1,}";
string input = @"^@*#(#))#__##
hellow world
dfafa
fdadfa
afafa
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}