package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z a-z 0-9 * - + = _ . # ~ ! ]{1,}`)
var str = `^@*#(#))#__##
hellow world
dfafa
fdadfa
afafa
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}